воскресенье, 4 января 2015 г.

Running intercepter-ng [console edition] on new iOS versions

I know there is a problem when you try to run old bin on new iphones\ipads, it gives 'illegal instruction' error . Today i found how to avoid it by patching 2 bytes:

# sed -i 's/\x00\x30\x93\xe4/\x00\x30\x93\xe5/g;s/\x00\x30\xd3\xe4/\x00\x30\xd3\xe5/g;' intercepter_ios

It's necessary only for one time and then it should runs just fine.